Eve Online Anomaly Ratting Bot Release

announcement
sanderling
nullsec
anomaly
ratting

#305

Are you using the downloaded version of this framework to do this anom ratting … or do you have to make edits and changes?


#306

I have error here
FirstOrDefault()?
Method doesn’t find.
Pls help. I need to solve this docking problem asap=(


#307

Hello, Guys.
I found how to launch 2 drones not 5.
Also solved problem with name of anomaly.
Now I need my Gila to warp at 0 to Station and dock.
Cant find working code for that.
Please, help.


#308

Tnx it works now :slight_smile:


#309

Hey guys,

Thanks for creating all of this, and discussing edits to the code,
It’s really helped myself to learn more about coding and editing, and is why I really enjoyed it,

For myself, I Don’t think I’ll ever actually use any of this in game, as I don’t like the idea of it. I have simply used it as a reason/initiative to teach myself now to work with C# and how Variables and definitions work in a system
People like @Viir Fuzzy @Terpla and Master, thank you For your responses in these threads, just looking at how you view things, and edits made have helped me greatly learn.

So far i’ve created a few versions based on code listed here and my own to create ones for Drone ships mainly, but the next one I’m a little Trumped with
Was planing to create an edit for a rattle, I’ve done everything with it, but For some reason it doesn’t always use its launchers, I was using the Meta4 RHML’s
Has anyone experienced this issue?


#310

Does the bot use rocket launchers sometimes or do not use them at all?


#311

Is there anyway to run this on a 32bit system? Stuck with my laptop thats 32bit and it won’t run it.


#313

@Master
Hi, i really like this kind of stuff. I’m trying personally find how it works but i stuck please help me.
I need help about align. It doesn’t click on sun (current system info panel) + click on instadock bookmark. But if i click manually on sun then move mouse cursor on instadock bookmark and open menu (warp,warp with…,align etc…) its clicking on align. I tried so many thing memorymeasurement stuff didn’t work. How can i fix it?


#314

I scoured the forum for 2 weeks and still can’t figure out how to recall drones before warping off. I tried using the virtual key code shift R by modifying retreat.cs but that doesn’t work either. Tried implementing all the possible solutions and hints in the previous posts but to no avail. Any help?


#315

Taken from default mine.ore.cs:

if (returnDronesToBayOnRetreat) {
	DroneEnsureInBay();
}

void DroneEnsureInBay()
{
	if(0 == DronesInSpaceCount)
		return;

	DroneReturnToBay();
	
	Host.Delay(4444);
}

void DroneReturnToBay()
{
	Host.Log("return drones to bay.");
	Sanderling.MouseClickRight(DronesInSpaceListEntry);
	Sanderling.MouseClickLeft(Menu?.FirstOrDefault()?.EntryFirstMatchingRegexPattern("return.*bay", RegexOptions.IgnoreCase));
}

#317

I’m trying to click in the menu that pops up when you right click on an individual drone in the drone window, and I’m getting this error:

Error CS0029 Cannot implicitly convert type ‘Sanderling.ABot.Bot.Task.MenuPathTask’ to ‘Sanderling.Motor.MotionParam’

I’m using ClickMenuEntryByRegexPattern as extended by Terpla like so (from the “fuzzy building a bot” thread):

static public MenuPathTask ClickMenuEntryByRegexPattern(this IUIElement rootUIElement,
				Bot bot,
				string menuEntryRegexPattern, string menuNextStep)
			{
				if (null == rootUIElement)
					return null;

				return new MenuPathTask
				{
					Bot = bot,
					RootUIElement = rootUIElement,
					ListMenuListPriorityEntryRegexPattern = new[] { new[] { menuEntryRegexPattern }, new[] { menuNextStep } },
				};
			}

here’s the line:

yield return droneMenuResultSelectOrbitMenu.ClickMenuEntryByRegexPattern(bot2, "orbit", "20 km");

All I’m trying to do is orbit my drones instead of my targets (I get a yellow boxing issue if I orbit targets in my current setup). droneMenuResultSelectOrbitMenu is a local variable that’s a Sanderling.Parse.IMenuEntry. What I really don’t understand is that AnomalyEnter.cs uses this method with a local variable of type IMenuEntry and it works just fine.

How do I get this to work? Sorry if the answer is really obvious but I have only a little coding experience so I’m learning as I go. If I need to provide more info just let me know. Thanks!


#318

Bot is showing ‘App interface not ready, update etc’

Also bot is only clicking on top left icon - i remember there was a fix for this but I can’t find it anywhere. Any tips?


#319

He’s trying to warp on save spot. Local chat is not detected or its enemy in there.


#320

Must be issue with new chat system then? I don’t know how to edit the config file, but I had this working before…

Thanks for fast response though mate <3


#321

fix for local chat detection is posted here:


#322

I can’t get this fix to work at all. I try to load the other bot into it but I must be doing someting wrong. Is anyone able to post a quick video on exactly how to do this?

IE. A couple of minutes, from download, to install, to running client?
(It isn’t difficult to edit details out of a video, like system, pilot, local etc - YouTube Link)


#323

same i dont understand how you are supposed to use that “fix”


#324

A-Bot Release v2018-04-04

This release integrates the March 2018 version of Sanderling memory reading. This version is adapted to recent changes in the EVE Online chat window. For more details, see the forum thread at Sanderling App Release March 2018

Thanks to @Anonymous0012, and others who helped testing A-Bot.

You can download the app executable file from


#325

Where can I find a list of what modules the bot can use? I am shit at coding and feel like I’m completely lost. It won’t activate Gist booster. Won’t touch T2 XL. I had to manually get the tooltip for the launchers and I’m just generally feeling a bit lost


#326

How can this A Bot be made to orbit enemies while activating afterburner?