Problem with eve online mining bot

Hi, i have a problem with the eve online miner bot.
It mines just fine, really a good work, it is impressive.
The only problem is that it doesn’t dock when the ore hold is full.
The bot says that it doesn’t know where to dock since he didn’t dock in this session.
Checking the code i noticed that the default station is set to null, is there any way to get passed that? I can’t change the code myself and i can’t download the github rep, so what can i do?

I solved it by downloading all the bot files and executing it in local enviroment, changing the line after the control on the cargo. I replaced the control on the variable with the command given when you have to escape with less than 50% of shield hp, if anyone else has the same problem.

Hello Lomeglio!

No need to download or edit files. In this case, there are multiple ways set the station.

The easiest way is to dock at a station. The bot remembers the station in which it was last docked, and docks again at the same station when the ore hold is full. For example, you can also start the bot while docked in a station. When it undocks, you can be sure it has replaced the default you mentioned.

You can skip that step by setting the station name using the app-settings in the configuration interface:
Enter this text into the app-settings textbox in the app configuration interface at https://catalog.botengine.org/08C2F5B083533BAAA290083127B29E315BC6BF17E6FC10EC0278BB8EC6151A51/configure-run-app/eyJvbmxpbmVTZXNzaW9uIjpmYWxzZSwiYXBwU2V0dGluZ3MiOiJsYXN0LWRvY2tlZC1zdGF0aW9uLW5hbWUtZnJvbS1pbmZvLXBhbmVsPVwiZW50ZXIgeW91ciBzdGF0aW9uIG5hbWUgaGVyZVwiIiwicGF1c2VBcHBLZXlzIjoiIiwic2Vzc2lvbkxlbmd0aExpbWl0IjoiIn0=

last-docked-station-name-from-info-panel="enter your station name here"

image

You can also set that threshold using the configuration interface:

last-docked-station-name-from-info-panel="enter your station name here", run-away-shield-hitpoints-threshold-percent=50

okay, and is there a way to make it dock at a structure instead of a station?

I solved it by doing few tries and twiking the code a little bit.
Now i can mine and compress my ore without having to transport it for hours like yesterday

1 Like

Any chance you can share your code ?